Jump to content
Corsair Community

RGB Lights Lagging / Stunning


VapeArt
 Share

Recommended Posts

Hello to everyone!
Recently, the RGB lights of my H100i Elite Capellix, SP Fans, Glaive RGB Pro and K55 have been lagging/stunning after starting the iCUE software. But when I turn off the software (with Hardware Lightning running), the lag disappears and the animations run smoothly.
I tried disassembling and reassembling all parts and cables, then I tried uninstalling and reinstalling the iCUE software several times, but it didn't fix my problem.
Lag/stun occurs similar to the video below.
This problem is always present, not just under load.


YouTube Video

Link to comment
Share on other sites

Posted (edited)

Are you on Ryzen?

AMD has some USB lag/intermittent connexion issues that they are adressing with a new Agesa revision that is just being released.

If that's the case, check your mobo's support page if there's a bios update

Edited by LeDoyen
Link to comment
Share on other sites

Link to comment
Share on other sites

  • Corsair Employees

If you are on Ryzen a few things can be the cause and all related to issues with the Ryzen platform and not related to our products or iCUE itself. First is the random USB disconnect issue on Ryzen platforms that support PCIE 4.0, and the other is the newer fTPM bug that @LeDoyen pointed out. Both require BIOS updates to resolve, though the fTPM BIOS update is just now being rolled out. We would recommend that you update your motherboard BIOS to the latest version available from your motherboard manufacturer's website for your board, and to also make sure you have downloaded and installed the latest chipset driver directly from AMD's website.

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...