Jump to content
Corsair Community

Dark Core RGB Pro firmware stuck on v. 0.6.23


Recommended Posts

I bought a Dark Core RGB Pro mouse on Amazon a week ago and the firmware of the Mouse is stuck on v. 0.6.23.

There is an update available on iCUE and the Dongle updated fine, but the Mouse keeps on failing when I try to update.                                                                   Now, because the mouse and dongle are on different firmware versions, they don't pair and wireless function does not work.                                                       Mouse connected to the USB cable and connected via Bluetooth work fine though.

The Dongle is currently on FW v. 2.4.14 but I also have v 5.0.41 and the Mouse is stuck on v. 0.6.23 like I have mentioned already. 

I've tried manual firmware update with a zip files that I received from Corsair Support, but it also fails.                                                                                                        I've tried different versions of iCUE but they all have the same result at the end - "Firmware Update unsuccessful."                                                                                  I've tried holding the FWD and BACK buttons and then switching the mouse on before trying to update.                                                                                                    I've tried holding the PROFILE button and then switching the mouse on before trying to update.

I have the following and none work:                                                                                                                                                                                                                  iCUESetup_3.20.80_release                                                                                                                                                                                        iCUESetup_3.29.110_release                                                                                                                                                                                        iCUESetup_3.30.97_release                                                                                                                                                                                          iCUESetup_3.31.81_release                                                                                                                                                                                                                                  iCUESetup_3.32.80_release                                                                                                                                                                                    iCUESetup_3.33.246_release                                                                                                                                                                                                                              iCUESetup_3.37.140_release                                                                                                                                                                                                                              iCUESetup_3.38.61_release                                                                                                                                                                                        iCUESetup_3.38.88_release                                                                                                                                                                                                                                iCUESetup_4.11.247_release                                                                                                                                                                                    iCUESetup_4.22.203_release

Is the firmware too old for iCUE or which iCUE version can I use?

Does anyone have the DONGLE firmware compatible with MOUSE firmware v. 0.6.23 that I can use?

Something that I did notice was that as soon as the firmware update starts, the mouse disconnects from USB (I can hear the windows tone for USB device disconnecting) and the update then fails shortly thereafter.

Any ideas of what I can do will be appreciated.

 

Link to comment
Share on other sites

  • 3 weeks later...

I guess the Corsair firmware issues come from the fact that each device has it's own firmware, dongle and mouse...and whenever you update one of them first, it may lose pairing....maybe there is a specific order, or steps to follow to update them in the same time.

I have same mouse dark core rgb pro  but SE version...and lost pairing when updating dongle firmware...the mouse itself is not even detected in iCue anymore (tested with 3. and 4.)./ only dongle is detected in iCue.

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...