Jump to content
Corsair Community

Virtuoso RGB SE MIC Light & Dark Core Pro SE Profile Lights


Recommended Posts

Hello all!  Since the latest update for the Virtuoso RGB SE (5.3.70) and Dark Core Pro SE (5.0.41), both devices have been acting strangely.  I have both paired in multipoint mode with my Virtuoso RGB SE Receiver and up until recently I had zero issues.

Headset Issue:  After going into sleep mode, when you pick up the headset and it wakes up, the MIC LED goes through its power on sequence, but then turns off so it does not indicate if the MIC is active or muted.

Headset Expected Behavior: When you pick up the headset and it wakes up, it cycles through the MIC LED colors then goes to green indicating the MIC is not muted and active.  This has worked until last firmware update.

Headset Video: 

Mouse Issue: What is occurring now is, the mouse profile selection LEDs (the 3 on the left side) when you wake up the mouse does not light up to tell you what profile you are on.  If you map or use the profile selection button it will light up to indicate what profile slot you are using....until it goes to sleep and then the process occurs again.

Mouse Expected Behavior: The profile indicator is on at all times unless the brightness slider is set to 0% (I have mine set to 100%).  This has worked until last firmware update.

Mouse Video: 

 

Link to comment
Share on other sites

  • Corsair Employees

Hi j0nsc,

Attempt to repair the iCUE software.

Control Panel

Programs and Features

Right Click the iCUE software

Select Repair

Restart computer

 

Reset the headset

To soft reset your headset make sure your mic is plugged in:

1. Make sure your headset is currently unplugged.

2. Make sure your headset is powered on.

3. Hold the Mute button on the headset down for about 15 seconds.

4. Switch the headset to wired mode and then back to wireless mode.

 

If issues continue,

Export your profiles before continuing

We recommend performing a clean install of iCUE. Please follow the steps below:

 

  1. Open your computer's Control Panel.
  2. Open the Programs and Features options.
  3. Select Corsair Utility Engine in the list, and then select Uninstall.
  4. Press Window Key + R to open the Run command.
  5. Type %appdata% and press Enter.
  6. Delete any Corsair folders in the window that pops up.
  7. Return to the Run window and type %localappdata%.
  8. Delete any Corsair folders in the window that pops up.
  9. Open File Explorer and navigate to C:\Program Files (x86)\ for iCUE 3, or C:\Program Files\ for iCUE 4.
  10. Delete any Corsair folders in that folder.
  11. Type Regedit in the Run window and then click OK.
  12. Go to HKEY_CURRENT_USER\Software\ and delete the Corsair folder.
  13. Go to HKEY_LOCAL_MACHINE\SOFTWARE\ and delete the Corsair folder.
  14. Restart your computer.
  15. Download a new installer file for iCUE from Corsair.com and reinstall.


 

If you need assistance with these steps, please reach out to our support team.

 

Link to comment
Share on other sites

I've joined up to say I'm experiencing exactly the same thing with my Virtuoso SE. I followed all of the steps above, and thought finally that a fresh install worked, as the mic status light immediately lit up green upon first turn on and link of the software to headset and RGB profile.

However, as soon as I turned it off, and back on again, and it loads the RGB from iCue, it's back to it's usual self and not illuminating when switched on.

Link to comment
Share on other sites

I just saw this thread and created a new one.  I am noticing the same behavior on my Corsair Core Pro SE.  Looks like something broke in the update.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...