Jump to content
Corsair Community

Corsair K70 Mk.2 keyboard "D" stopped working


Recommended Posts

Hello guys,

I have a Corsair K70 Mk.2 RGB MXCherry Red(English) keyboard . The "D" key on my keyboard stopped working yesterday during an Fo76 session.

Have tried to a keyboard soft-reset & iCUE 4 clean Install. Sadly this did not restore function.

The hardware lighting still works on the key though. Bought the keyboard 1 year & 7 months ago.

Are there any options or methods to resolve this issue myself, or should I go to service center?

Any advice appreciated.

Link to comment
Share on other sites

  • 3 weeks later...

I have K100 OPX switch keyboard with a "D" key issue as well. As far as I can remember all of the keyboards I bought from Corsair develop an issue on them right before or after the warranty expires for me. I have cleaned mine but I do that normally every 3rd day to begin with. Tried the compressed air and it didn't help.

I am not sure if corsair lubes the switches from the factory or not. I am wondering if the lube might have dried up and is causing the issue. I mean something could get in there but it is a slim chance with the space tolerance. I mean something would have to blow up under the key cap and fall between the stem and the switch. But anything is possible in this day and age.

Mine works okay if you are fast hitting it. But if you are holding it down or typing slow, it down it gets stuck at the bottom. It makes the whole keyboard lag and causes other issues as well from the stuck key. I wished Corsair would take the swappable switch route to fix these issues. WE can only hope for it in the future and a wireless version to get rid of that jump rope they give you for a cord with it.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...