Jump to content
Corsair Community

iCUE 4 not launching


Recommended Posts

hi,

Since i update my computer to windows 11, iCue is not opening anymore. 

When i start my computer i can see the icon in the taskbar. But, when i try to click (right or left), the app is trying to open (i can see a white window appearing) and then quit suddenly.

I already tried to reinstall properly (delete programdata\corsair and the regedit corsair file) but i've still the same issue.

I also tried to launch iCue in admin mode but same problem.

However iCue is laucnhing in Safe Mode

Do somebody have any tips to handle this ?

Thnak you

Link to comment
Share on other sites

  • Corsair Employees

Follow the steps below to clean uninstall and install iCUE. Also what exact build of Windows 11 did you update to?

https://help.corsair.com/hc/en-us/articles/360025166712-Perform-a-clean-reinstallation-of-the-Corsair-Utility-Engine-iCUE-

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...