Jump to content
Corsair Community

Brand new RM850x Burning 12 fans from different stocks/brands ?


Recommended Posts

Hello everyone,

I'm coming here because I am desperate now, I bought a new RM850x last week for 140€, and a XIGMATEK Aquarius Plus Arctic (with 7 fans included) for 170€ earlier this week.

I am used to building PCs, this is like the 5th time so I did as always, and built everything up. Once I pressed the start button, I started to hear very strange and scary noises from every single fans in the case, along with a burn smell so I immediately unplugged the thing. I checked all the cable and the plugging, I did not make any error so I tried to start it again, and it work "properly". Only some of the fans had one ridiculous green LED on a corner, whereas others were full lightened but with random green and blue all over. On the 7 fans, not one was working as it should have. Then the LED Hub fried in my hands. Because it was xigmatek I tought the hub was faulty and that replacing it would solve the problem, so I order a 3 xigmatek fans (30 more € to the bill) to get a new LED hub. I received it 2 days later and plugged it. It did not fried, but the LED were still not working, and I still couldn't change any of the colors.

Pretty annoyed, thinking it was Xigmatek fault for making bad fans/hub, I ordered for 160€ of Corsair LL120 RGB fans yesterday. I received it all today, so I closely followed all the instuctions, step by step, changing the SATA cable, and the plugg location on the PSU to make sure it would not happen again. I only plugged two fans, to make sure if there was a problem, I would not fry all of them. And holy molly was I right. The 2 brand new LL120 had the same noises, the burnt smell, and now one of the fans have this ridiculous green light, while the other is full Blue/green. Icue won't change any of the color...

I now have 17 fans that will not work, 12 of them have completely fried LEDs. So the only possibility I see, is that the 140€ RM850x was faulty all along, and fried for around 200€ of LED fans... Has it happened to anyone here ? Or does anyone have a solution ? 

Link to comment
Share on other sites

My system :

OS : Win10

Case : Xigmatek Aquarius Arctic PLUS

MB : Gygabite B550 AORUS ELITE V2

Processor : AMD Ryzen 7 5800x

GC : Nvidia RTX 3080Ti AORUS MASTER

PSU : Corsair RM850x

RAM : Corsair Vengeance LPX 32GB (2x16) ddr4 3200MHz

 

 

Link to comment
Share on other sites

what modular cables do you use on the PSU? those that came with it in the box?

What you describe sounds like plugging 5V ARGB to 12V, but it should not happen if you use the factory corsair cables.

Link to comment
Share on other sites

Yes I only used the cables that came with the 850x

The LED node only has this usb kind of plug that is directly connected to the MB so the 12V is not even occupied

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...