Jump to content
Corsair Community

Scimitar side buttons not working suddenly


Recommended Posts

hi

My Side buttons aren't working suddenly. No changes what so ever.

I use it for WoW but they are not working. I tried using notepad and they are still not working

my left click/right click are fine.

Is there a way to upload the log files?

 

 

Link to comment
Share on other sites

  • Corsair Employees

Hi aymanzone,

We would first suggest you try a soft-reset of the mouse. This will clear the mouse’s internal memory, which often corrects issues such as the one you are experiencing. Please follow the directions below:

1: Unplug the mouse.
2: Hold the left and right mouse click.
3: While holding the left and right mouse, plug in the mouse.
4: Hold the left and right mouse down for 10 seconds.
5: Release the left and right mouse.
 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...