Jump to content
Corsair Community

K100 keyboard delay turning on and unable to change lighting


Recommended Posts

I have a weird situation that I'm not familiar with on how to resolve it. I have a K100 OPT Mech keyboard, of course. When I bought it last month and first plugged it in, it worked just fine. The keyboard would turn on/wake up when I pressed the ON button on my computer. I was able to do the pre-post operations (get into the BIOS).

Then something simply changed that I have no clue as to what. The keyboard no longer turned on at pre-post. It's delayed and turns on after posting and when the Windows logon screen loads. I can not longer get into the BIOS because the keyboard isn't even on pre-post. Now, when I load the iCUE software, I can't even change the lighting modes. Now, I never really set up any profiles or changed the lighting before. I was quite happy with the default rainbow wave. But now, it seems stuck with all keys red. I have Corsair RGB RAM sticks, they're stuck on red. I have a Corsair mouse, it's stuck on red. I have deleted all the profiles that showed up in iCUE. I have tried doing the Factory Reset steps (plugging in the USB plugs while holding the ESC button... keyboard then passthrough) and still nothing. I reboot the computer and the default rainbow is loaded, but not on the RAM sticks. The moment I open the iCUE software, everything turns red and I'm unable to change anything.

I can live with the lack of being able to change the lighting colors, but I need to resolve the issue of the delayed keyboard power on issue. I had recently installed a SoundBlaster AE7 card (after this delayed power on issue began) and I need to get into the BIOS to disable the onboard audio, but I can't because for whatever reason the keyboard doesn't turn on when it's supposed to. Does anyone have any ideas on how to resolve these issues?

Link to comment
Share on other sites

  • Corsair Employees

That comes down to when the system enables the USB ports the keyboard is plugged into and you should reach out to your motherboard manufacturer who based on the description of the other issues is MSI. As for the red LED issue that is most likely caused by having MSI software such as Mystic Light/Dragon Center/One Center/etc... installed and it is taking exclusive control over third-party RGB devices on the system.

Link to comment
Share on other sites

if it is a msi motherboard , go into bios and disable the "msi fast boot" and "fast boot" options.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...