Jump to content
Corsair Community

New PSU : SSD ok, HDD not recognized


Recommended Posts

Hello, just upgraded from my 500w PSU to a brand new Corsair SF750.
I have 4 drives

1 NVMe (M.2)
1 SSD (sata)
2 HDD (sata)

Since I changed the PSU, my NVMe and SSD are still working just fine, but HDDs aren't.
 

I tried pretty much everything : 

  • Check the cables
  • Use the sata cables from the PSU box
  • Switch between the SSD and HDD cables (power and data)
  • Tried a brand new HDD

In every situation, the SSD (and NVMe) are still working, but the HDD are not even recognized in BIOS.
I check the cables a dozen times. I reset the BIOS configuration. I unplugged the PSU and removed for Motherboard battery for a minute (and then forced a factory reset). NOTHING.

Even the brand new HDD isn't recognized.
That's weird the SSD is still working though.

Any idea?
Thanks

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...