Jump to content
Corsair Community

iron claw wireless mouse not detect by pc


Recommended Posts

Hello,

I've had a wireless iron claw for a while now, and frankly it's great. But for a few days I have had a problem, it has disconnected, nothing serious it has already happened several times, just plug it in and pair it, but the problem is the following, when I plug it in my pc does not no longer detects it. It lights up when I plug it in but I can't use it, ICUE doesn't detect it for pairing and it doesn't show up in my device manager. I tried several things, restarting pc, changing usb port, changing cable etc but nothing worked. The corsair cable being HS I use another one that works since I use it to transfer files from my phone (the corsair cable sends me an error as soon as I plug it in, it puts Unknown usb device ( device descriptor request failure) I tried everything to fix this error and nothing worked), the other cable being functional I didn't worry about it anymore.

I read that it could be a driver error but I checked for updates and everything seems ok. I really don't understand, and I don't have another mouse on hand, it's a hassle.

Ps the bluetooth works normally, only the 2.4 GHz does not work, but I use a lot of macro etc not available in bluetooth same for the personal setting of the dpi.

 

I hope to find a solution with the support, thanks in advance


Lucas

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...