Jump to content
Corsair Community

K100 Light Issue


Recommended Posts

I have a K100 Keyboard with optical keys and the Left Alt key seems to have no Red light anymore. The rest of the keyboard is working perfecting and the key works its just a lighting issue. The unit is only 6 months old, I have performed a reset the keyboard, updated iCue and forced a firmware update with no luck.

Has anyone got any other tips or ways to make this light work again, the non matching color is driving me crazy.

Link to comment
Share on other sites

  • Corsair Employees
3 hours ago, Aussie77 said:

I have a K100 Keyboard with optical keys and the Left Alt key seems to have no Red light anymore. The rest of the keyboard is working perfecting and the key works its just a lighting issue. The unit is only 6 months old, I have performed a reset the keyboard, updated iCue and forced a firmware update with no luck.

Has anyone got any other tips or ways to make this light work again, the non matching color is driving me crazy.

Please submit a ticket with support at this point to investigate a potential warranty replacement -- simply visit https://help.corsair.com/hc/en-us/requests/new to create a new request.

Thank you.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...