Jump to content
Corsair Community

iCUE v4.22.203 Release Notes


Corsair Nick
 Share

Recommended Posts

  • Corsair Employees
Software Enhancements
  • Privacy Tab has been added to Settings
  • Fixed an issue that caused Philips Hue to crash iCUE when enabled
  • Fixed the LT100 tower names in Quick Lighting Zone
  • K100’s Control Wheel will no longer have its lighting impacted by polling rate changes
  • Resolved text overflow issues with certain translations
  • Resolved some issues with customizing custom Scenes
  • NVIDIA 3080 Ti Founders Edition is now supported in iCUE
  • The following legacy devices are now supported in iCUE 4:
  1. SABRE RGB
  2. SABRE RGB Optical
  3. SABRE RGB Laser
  4. VOID USB
  5. VOID Surround
  6. VOID Wireless

View full version

Link to comment
Share on other sites

This update breaks iCUE integration for Stream Deck again. image.png.5e29dfcc0ef764a0f5bba28cb5e08d65.png

Link to comment
Share on other sites

So new iCue 4.22.203 just released today.  Have not tried it yet.  Anyone with success?

Doesn't look like anything for us Corsair One owners has been resolved unfortunately.  Maybeee they left it out of the notes? (Wishful thinking??)  What do you guys think?

  • Thanks 1
Link to comment
Share on other sites

Dumb question... why do you not actually post a link to the download when you make a post like this?

I mean it's not showing as an available download in ICue itself and the "full version" link doesn't have a download either so we have to go hunting for the actual download link back on the main site. I mean it's not super difficult, just seems... I dunno, like an oversight?

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

I NEED ANSWERS!

I upgraded to the new version, but my usb dongle is not working. Is there any solution to this? It happened since the update and my CORSAIR VIRTUOSO no longer works wirelessly.

 

Any answer?

Link to comment
Share on other sites

1 hour ago, Phenoz said:

I NEED ANSWERS!

I upgraded to the new version, but my usb dongle is not working. Is there any solution to this? It happened since the update and my CORSAIR VIRTUOSO no longer works wirelessly.

 

Any answer?

i had this problem a few releases ago and contacted support, for some reason my dongle was bricked completely so it was replaced

Link to comment
Share on other sites

It is the 2nd version that is not automatically detected by the software itself to update, I always have to update manually...

Link to comment
Share on other sites

3 hours ago, LinkinParkBoy said:

It is the 2nd version that is not automatically detected by the software itself to update, I always have to update manually...

How do you update it? Do you have a link?

Link to comment
Share on other sites

Link to comment
Share on other sites

I cannot get plugins to work after updating. my Asus Board and GPU wont show no matter what i try.

Edited by t1971
Link to comment
Share on other sites

  • Corsair Employees

Thank you all for bringing this update issue to our attention.  The update feature in the iCUE app should be working now as intended.  If you're still having issues, please let us know.

Link to comment
Share on other sites

22 hours ago, kevjtro said:

This update breaks iCUE integration for Stream Deck again. image.png.5e29dfcc0ef764a0f5bba28cb5e08d65.png

Same on both of my machines.

Link to comment
Share on other sites

  • Corsair Employees
4 hours ago, t1971 said:

I cannot get plugins to work after updating. my Asus Board and GPU wont show no matter what i try.

Make sure your Armoury Crate, and the relevant modules within Armoury Crate for your devices are fully updated by going to the Update Center in the Asus software.

Link to comment
Share on other sites

21 hours ago, zguy85 said:

So new iCue 4.22.203 just released today.  Have not tried it yet.  Anyone with success?

Doesn't look like anything for us Corsair One owners has been resolved unfortunately.  Maybeee they left it out of the notes? (Wishful thinking??)  What do you guys think?

Strange that Corsair ignored customers who have paid $5,000 for their products. Aren't these the most expensive products from Corsair? 

  • Sad 1
Link to comment
Share on other sites

A little bug that affects my pc since a couple of versions... when the system goes in sleep, after it wakes up the iCue icon in the SystemTray disappears even if the software is still running. I must kill all Corsair related processes to b able to open the main window again.

Hope it helps!

 

Baio

  • Like 1
Link to comment
Share on other sites

Any update on when fixes for the Corsair One will be included in these iCue updates?

Link to comment
Share on other sites

I just figured out my nexus no longer can read temperature from my Red Devil 6900xt
😞

reinstalled gpu driver to see if it would resolve the issue and it doesn't. The sensor is no longer available in icue
Link to comment
Share on other sites

You guys actually added back the old headphones with this release!
Ignoring everything else, thank you to whoever at corsair has been fighting tp reverse the decision to abandon existing users.

  • Like 3
Link to comment
Share on other sites

Every time I get a little excited when a new version comes out because I'm always hoping that someone will enable the button on the LT100 tower to become a power ON/OFF button. It would be nice when going to bed for the night to be able to turn them off without having to unplug it or go into the iCue device settings and turn down the brightness to 0. 

Link to comment
Share on other sites

On 3/30/2022 at 7:16 PM, BlaiseP said:

Same on both of my machines.

 

image.png.957018866c66b48572e11330c2e417cd.png

 

Me too. And the software doesn't allow seamless downgrade back to the prior version either, which is a pest. Breaking compatibility with your own sister company's product smacks of basic QA fails.

Kudos to the Corsair peeps who have been working to bring older hardware into the iCue 4.x setup tho.

Edited by Citizen Crazed
Link to comment
Share on other sites

23 hours ago, istehwin said:
I just figured out my nexus no longer can read temperature from my Red Devil 6900xt
😞

reinstalled gpu driver to see if it would resolve the issue and it doesn't. The sensor is no longer available in icue

ddu'd and reinstalled gpu driver and now functional

Link to comment
Share on other sites

On 3/29/2022 at 4:06 PM, kevjtro said:

This update breaks iCUE integration for Stream Deck again. image.png.5e29dfcc0ef764a0f5bba28cb5e08d65.png

Here is the error in the log file for the plugin.

2022-03-31T21:09:23 I sdp.connection_manager: Device pixel ratio: 1
2022-03-31T21:09:23 I sdp.connection_manager_base: Start connecting to StreamDeckApp
2022-03-31T21:09:23 I sdp.connection_manager_base: Successfully connected to StreamDeckApp
2022-03-31T21:09:23 I sdp.connection_manager_base: Start registering plugin with StreamDeckApp
2022-03-31T21:09:23 I sdp.au_sdk_controller: Start connecting to iCUE
2022-03-31T21:09:23 I cas.client: Start connecting to iCUE
2022-03-31T21:09:23 W qt.remoteobjects:  Signature mismatch for AutomationSdkIpcReplica "AutomationSdkIpc"
2022-03-31T21:09:23 C cas.client: Error during Replica initialization. Replica's current state is QRemoteObjectReplica::SignatureMismatch; waitSuccess: false; initialized: false; replicaValid: false
2022-03-31T21:09:23 I cas.client: tryFetchServerVersionWithDynamicReplica(): version 5 fetched
2022-03-31T21:09:23 C sdp.au_sdk_controller: Incompatible serverVersion(5) and clientVersion(4)

  • Like 1
Link to comment
Share on other sites

I'm having a serious problem with iCUE now, both my Dominator rams + my lighting node aren't shown in iCUE,  I can't control their lighting effects, they're turned on with the hardware lighting only!

I've tried to uninstall Armoury Crate, to re-install iCue, even I've re-installed Windows, tried to switch the rams, with different slots, take off the lighting node,

Please tell me what's wrong, my motherboard is Asus Rog Formula Z690 and my rams are Corsair Dominator CMT32GX5M2B5600C36

Link to comment
Share on other sites

1 hour ago, Yami-Samurai said:

I'm having a serious problem with iCUE now, both my Dominator rams + my lighting node aren't shown in iCUE,  I can't control their lighting effects, they're turned on with the hardware lighting only!

I've tried to uninstall Armoury Crate, to re-install iCue, even I've re-installed Windows, tried to switch the rams, with different slots, take off the lighting node,

Please tell me what's wrong, my motherboard is Asus Rog Formula Z690 and my rams are Corsair Dominator CMT32GX5M2B5600C36

Other have reported this to get the RGB on your ram working.

Disable SPD write in bios.  SPD Write = FALSE

  • Like 1
Link to comment
Share on other sites

1 hour ago, kevjtro said:

Other have reported this to get the RGB on your ram working.

Disable SPD write in bios.  SPD Write = FALSE

Thanks for this mate, it truly worked!

But I still can't have the lighting node working, what do I need to do for it? 😄

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...