Jump to content
Corsair Community

Virtuoso XT not detected by Windows when plugged in via USB


Recommended Posts

Hello!

I`ve been experiencing this issue since I received the Virtuoso XT last week. The headset works just fine with every other connection type (3.5/bluetooth/wireless) but it just refuses to work when plugged in via USB. When I plug it in I don`t even hear the usual Windows sound that plays when you plug in other USB peripherals like a mouse or keyboard for example. However, it charges just fine. And, of course, it doesn`t even show up on iCue (I have the latest version installed, iCUE 4.21.173).

This is the second Virtuoso XT with this issue (first one was returned as I believed it was a faulty harwdware issue), so I doubt it is a problem related to a faulty USB cable (and if this was the case, it shouldn`t charge just fine right?)

I also doubt that it is just a problem related to the laptop I`m using (Windows 11), as I`ve tried plugging in the headset on a Surface Pro 4 (Windows 10) and an old desktop PC (Windows 10) with the same results; the headset just doesn`t get recognised by Windows/iCue.

I`ve tried LOADS of troubleshooting guides that can be found on the Corsair site but, so far, no dice. 

Some of the things I`ve tried so far:

- Clean iCue reinstallation (https://help.corsair.com/hc/en-us/articles/360025166712-Perform-a-clean-reinstallation-of-the-Corsair-Utility-Engine-iCUE-)

- disabling USB sleep (https://help.corsair.com/hc/en-us/articles/4404450662285-What-to-do-if-your-Corsair-device-is-not-detected-on-startup-or-after-waking-from-Sleep-Mode)

- uninstalling every Corsair stuff from "Device Manager" and also "Devices and Printers"

- I read around that for some people the headset showed up as "unrecognised USB device" in Device Manager but it doesn`t even pop up in there for me

- headset soft reset by holding the mic button for 15 secs (while the headset is turned on, then turning off and back on)

- making sure the USB C end of the cable was plugged in all the way

- different USB ports

- different devices (doesn`t work on my laptop, surface pro 4 and old desktop PC)

Any ideas? I`ve already opened a support ticket but no reply so far, so I thought I`d try here too.

Thanks!

 

Link to comment
Share on other sites

  • Corsair Employees

It looks like the support team is helping you out at this point -- sorry we took a little bit longer to get to you! Tech Support will make sure we get this solved for you though.

Link to comment
Share on other sites

  • 4 weeks later...

Hi, I am having the exact same issue as described by Isenroth. I also tried the same steps he explained and I am still unable to see or use my headset while plugged in via USB.

Since this issue seems to have been solved by support, could we have access to the solution posted here so anyone else with the issue can fix it?

Thanks!

Link to comment
Share on other sites

Hey Abstulo!

Support hasnt solved this yet for me. Believe it or not I`m still dealing with this! I received a replacement unit yesterday but I`m still experiencing the same issue, so it wasn`t a case of a defective unit/USB cable or anything like that. If I manage to figure this out I`ll update this post, and please do the same if you find a solution.

Thanks 🙂

Link to comment
Share on other sites

  • Corsair Employees

Are you making sure the headset is set to USB mode? that you are plugging the USB cable directly into a USB port on the physical machine and not into some sort of USB hub/switch, dock, or KVM? And that you have checked the Windows sound settings making sure the correct output device is selected? And finally have you tried also restarting the programs outputting sound to make sure they are using the correct output as well?

Link to comment
Share on other sites

Hi Notepad,

Yes, the headset is set to USB mode and I`m plugging it in directly into one of the laptop ports (literally tried all of them just to see if anything changed), so no USB hub (although I`ve also tried pluggin into one cause why not at this point). As the headset is not even detected I can`t even select it as output device

Thanks!

Link to comment
Share on other sites

  • Corsair Employees

Are you making sure you are using the USB cable that was provided with the headset? Have you tried a different cable?

Link to comment
Share on other sites

  • 2 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...