Jump to content
Corsair Community

Ram Stick Not Detecting but still has RGB Lighting


Recommended Posts

Recently got 4 sticks of Corsair Vengeance RGB Pro 8gb 3600mhz DDR4 ram installed and it was working perfectly fine for a week (Checked available ram shown was 32GB just to be sure). I wanted to adjust rgb settings on it and so installed corsair iCue and updated the RAM firmware along with the bios of the motherboard afterwards. Not sure exactly how long after though (could be instantly or a few days) that I noticed only 3 sticks of ram were being detected (task manager showed 24gb available) and turns out the first stick in the slot wasn't detecting even though the rgb lighting works perfectly fine. I hadn't physically touched anything inside the computer and tried everything to fix it including force updating the firmware in iCue, swapping ram slots which just showed empty in the bios for that ram stick when I checked, downgrading bios, psychically cleaning ram etc however this ram stick appeared to still not be detected. Not sure if this is to do with the updating of the firmware/bios, an software issue which I caused, or an electrical surge which damaged it. Would like to know if there's anything that can be done to help.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...