Jump to content
Corsair Community

HS80 Wireless Reciever Firmware bug?


Recommended Posts

Few days ago I updated the Firmware on my HS80 Wireless reciever, but i have been getting an error that says unavailable when I restart my headset. Anyone else experience this problem too? 

Link to comment
Share on other sites

  • Corsair Employees
1 minute ago, Precise said:

Turn the headset off and on? Yes, it works for a a bit and then says unavailable again. 

It's a little more involved than that. This will disconnect the battery from the headset, and then reconnect it. All you would need to do is: 
 

Please make sure your headset is unplugged. 
Make sure your headset is powered On. 
Hold the Mute button on the headset down for about 15 seconds 
After holding the Mute button, hold the Power button until the headset turns on 


Then try testing the headset. If it is still having issues, please contact us again for further troubleshooting. 
 

Link to comment
Share on other sites

  • Corsair Employees

So sorry, essentially the same thing but with the power button

To soft reset your HS80:

Make sure your HS80 is powered off.
Hold down the power button until you see the lights on the headset flash.
Wait 15 seconds, and then power on your headset.
Test your headset and see if the issue is resolved.

Link to comment
Share on other sites

In your first post you said make sure HS80 is powererd On, but in this post you said make sure it powererd Off.
Anyhow, I tried the steps you said, and I also re-installed the ICue software. I will test for a bit and see if it works. This only started happening when I updated the firmware for the HS80 Wireless reciever

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...