Jump to content
Corsair Community

H150I Elite Cappellix Cooler Pump Disappeared from iCUE


Recommended Posts

Specs:

AMD 5950x

Asrock B550 TaiChi MOBO

iCUE version 4.21.173

Built a new PC two weeks ago and had no issues for about a week, then suddenly the pump won't light up and disappeared from iCUE. I am using the Commander Core that was included with my cooler, and it has 5 Corsair RGB fans plugged into it. All the fans are working and visible in iCUE. Based on my CPU temp readings I believe the cooler is working as well, and I am getting readings on the coolant temp from the commander core, it's just not lighting up and is not visible in iCUE. I have tried a clean install of iCUE (including regedit and %appdata% wipes), I have tried reverting back to the previous version of iCUE in case there was an update but I just can't get this damn thing to show up again.

Link to comment
Share on other sites

After getting an entire replacement cooler from Amazon (rather than deal with Corsair's onerous and glacial RMA policies) I determined that the problem was with the Commander Core's input jack for the pump. Replacing the Commander Core unit has fixed the issue.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...