Jump to content
Corsair Community

iCue No Longer Recognizing RAM After BIOS Update


Recommended Posts

Hey Y'all,

 

I recently update my ASUS motherboard BIOS from version 1003 to the latest 1304, and now iCue is no longer recognizing my ram. I went back and double checked that the "SPD Write" option within my BIOS was set to "TRUE", since I had to do that when I first installed. No other BIOS settings were changed when updating.

Even with that enabled, iCue is still not seeing my ram. Is there an update coming through the pipeline shortly that will address this?

Please let me know if there is anything else I can check that might be able to fix this.

 

Core System Specs:

Intel 12900K

ASUS Z690 ProArt WiFi

Dominator 6200C36 DDR5

3090 FE

 

Link to comment
Share on other sites

Okay, disregard.

I was able to get it working, for some reason my iCue wasn't pulling the latest version down even when I did "Check for Update".

 

Also the SPD Write option in ASUS BIOS is worded a little tricky, and should actually be set to "FALSE".

  • Like 1
Link to comment
Share on other sites

  • 3 months later...
  • Corsair Employees

Hey there! To clarify a little further, when updating the BIOS it will clear or reset any changes made within the BIOS and set them to default. ASUS Z690 boards have the SPD write disabled by default which can prevent iCUE from detecting the DRAM modules. This setting is listed in BIOS as SPD Write Disable. Set that to false and your DRAM modules should be detected in iCUE.

We have an article for this, in case anyone else runs into this: https://help.corsair.com/hc/en-us/articles/5718039999117-How-to-Enable-SPD-Write-on-your-ASUS-Z690-motherboard

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...