Jump to content
Corsair Community

Not getting right speed on my DD4 2 x 16 GB Ram 3200 MHZ, only getting 2133 speed ??


Recommended Posts

AMD Ryzen 7 3800X CPU

MSI MPG X570 Gaming Edge Carbon Wifi on latest BIOS(Version E7C37AMS.1E0)

Corsair CMW32GX4M2C3200C16 (Vengeance RGB pro 3200) RAM 2x16gb sticks

Cooler Master Gold 650W PSU

nVidea Geforce GTX1650

After update to BIOS - the memory only coming in at 2133 speed  Old BIOS had correct memory at 3200 MHz

Tried to use XMP OC,  Manual typed overclock, where 3200 speed is an option and tried MSI  Memory Try It, at 3200.  Booted into "memory incorrect, press F! to use default BIOS- Memory settings...  Anyone out there can offer any suggestions.   Last attempt, and wouldn't even load BIOS, I had to use USB BIOS port, at back of my machine, which did load - but still says 2133 speeed.  Appreciate your assistance.  

Thanks

Link to comment
Share on other sites

I rolled back the BIOS, one step - 2nd most recent version.  Seems all good now - I loaded BIOS, and engaged  Xmp to option 1.   Only thing is - missing out on latest updated BIOS that enables TMP 2 and is ready for WIN11 Upgrade ?   Hope a revised BIOS, that won't affect my RAM speed comes out soon!

Link to comment
Share on other sites

  • Corsair Employees

Thanks for the update.  A BIOS update may cause issues with such things as loading XMP.  Definitely keep an eye out for an update on the BIOS.  I would also recommend reaching out to the motherboard manufacturer and reporting the issue.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...