Jump to content
Corsair Community

Left control not being combined


Recommended Posts

The left control key is not being combined properly. The key press and release are properly detected but combinations like Ctrl-C results in a "c" instead of the copy command.

I confirmed the Ctrl is being pressed and release properly using the `xev` command on a Linux, and using the iCue software in a Windows (the key is detected when you try to create a new keys combination).

I have no idea what's going on. It's really weird to see how the key is pressed in `xev` but at the same time being ignored when combined - actually, I would say it was impossible to happen.

What I tried on the Windows OS:

  • Delete iCue
  • Delete the Windows drivers (devmgmt.msc > Keybaords > Uninstall HID controller)
  • Restart the Windows

I have also tried to reset the keyboard as described in your help article, but I see no difference. Actually, I feel the procedure is just not working at all because when I release the ESC key the keyboard light just turns back as it was configured.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...