Jump to content
Corsair Community

QL120 RGB Fans stuck on wrong color


Recommended Posts

Hi Everyone,

Some of my LEDS in 1 of my fans are stuck on the wrong color for the past half year. I have been trying to fix this for a long time but nothing worked.
Whenever I set my fans to white some LEDS give the color: purple.
If I set the color to green in ICUE the LEDS don't even light up. I feel like the LED in the fan itself broke somehow. 
My PC & fans are not even 1 year old. Is there any solution for this?
See some images here below:

Link to comment
Share on other sites

Can't see those pictures from here but yes, it sounds like dead green dies.

You'll have to open a support ticket with Corsair (link at the bottom of the page) to arrange a warranty replacement..

Have a look there for some official word from Corsair.

 

Link to comment
Share on other sites

18 hours ago, LeDoyen said:

Can't see those pictures from here but yes, it sounds like dead green dies.

You'll have to open a support ticket with Corsair (link at the bottom of the page) to arrange a warranty replacement..

Have a look there for some official word from Corsair.

 

Thank you for your response.
I'm sorry, I'm new on here. How do I create a ticket.
I really want this to be replaced.

Link to comment
Share on other sites

https://help.corsair.com/hc/en-us/requests/new - US link

 

Click on "contact us" below for additional assistance as well.

Edited by mpoffo
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...