Jump to content
Corsair Community

Commander Core XT not showing up in ICUE


Recommended Posts

Recently had to switch my motherboard and after doing it my commander core xt isn't showing up in icue not sure what happened. I've tried multiple things to fix it but nothing worked. I already put a ticket in currently waiting for a response fans and pump work but i need to be able to control the fans so it isnt too loud when im streaming

Link to comment
Share on other sites

Device detection is through the USB 2 pathway and that is through the MB's chipset.  Make sure you have installed the new motherboard's chipset driver.  However, recent AMD boards since x570 have issues with USB detection in general.  Many AMD users need a powered USB hub to make up for low output on the board side.  

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...