Jump to content
Corsair Community

K60 RGB PRO delivering many spaces when typing just once

Recommended Posts



I. have a K60. RGB PRO keyboard in OSX Monterey (12.2.1) with latest iCue.v.4.20.169 and latest firmware. v.4.21.18 that delivers several spaces when I am just pressing space once. This is very disturbing because man softwares understand those spaces as ending. of the phrase. and adding a. space to it. I have tried to adjust polling rate from 1ms to 4 or 8 and also switch debounce time without success.

I also. tried to adjust OSX settings. in Keyboard section for. keypress timings. but as. you here while I. type, no success.

I need help to solve it.

Link to comment
Share on other sites

  • 1 month later...

This was an issue for me on my K60 as well. I had to clean the switch contacts under the switch for the space bar but I would only advise this if you are 100% capable of doing disassembly carefully so you don't break anything when pulling the key switch and cap.

Overall, I am not too impressed with this keyboard or the switches.  Better than membrane but just not good overall.  What sucks is that it takes time to know if you don't like a KB so it isn't like you can just return it 2 months later for a full refund.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...