Jump to content
Corsair Community

iCUE H150i Elite LCD not working


Recommended Posts

Hi,

My LCD screen reads temperature, but has red RGB around it and does not get recognized by iCUE. I'm using the Commander Core that's built into the 5000t cases, with the coolers commander as an extension. I'm not a PC expert so I'm totally doing something wrong here, I just can't figure out what. I tried messing around putting all the fans in the Commander Core XT smart and also putting the fans related to the cooler in the cooler's hub. The RGB would just be red for everything connected to the cooler's hub. (Btw I don't have that exclamation mark triangle appear on the LCD)

Link to comment
Share on other sites

To clarify, the cooler fans are different than the case fans, I've now separated the cooler fans and the case fans in their own commanders and anything related to the cooler just has red rgb I can't edit whatsoever

Link to comment
Share on other sites

You mentioned that the screen reads temperature ... what's the temp?

Do you have any alerts?

 

Link to comment
Share on other sites

Not sure what you mean with alerts? The temperature is just around 30°C constantly

8 hours ago, DevBiker said:

You mentioned that the screen reads temperature ... what's the temp?

Do you have any alerts?

 

 

Link to comment
Share on other sites

Go to the "Alerts" screen for the cooler. Anything in there?

Link to comment
Share on other sites

On 3/2/2022 at 12:48 PM, DevBiker said:

Go to the "Alerts" screen for the cooler. Anything in there?

Hi, I know it's almost been a week but I got the LCD screen to work. I messed around with some cables, don't remember what I did but I tried every possible connection and turns out that only either the case or the screen can work. I'm guessing it's because they both have their own commanders or something? The case does keep hardware settings even though it doesn't show up in iCUE.

By the way my posts are limited and I couldn't DM you either, I'm guessing spam prevention. This is also why I put it aside for a while and just decided to live with it but it's been kinda bugging me still lol

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...