Jump to content
Corsair Community

Elite LCD Megathread


Recommended Posts

  • Corsair Employees

I have the same issue cant play with screen only liquid temp shown. Id rather not send it back as it was already a pain to install. I would gladly beta test the new firmware to see if it works if you want to give it to me.

Thank you for responding that you're experiencing the same/similar behavior.  I've created a ticket for you to send the unit in.

Link to comment
Share on other sites

  • Corsair Employees

I’m having problems with my icue lcd display, I got the default non-animated liquid temp display but I can’t edit the screen in the icue software.

My specs are:

Motherboard: Z390 Gigabyte Aorus Master

CPU: Intel 9900k

GPU: EVGA FTW3 RTX 3080

RAM: 32gb Corsair Vengeance RGB pro 3200Mhz

Thank you for responding that you're experiencing the same/similar behavior.  I've created a ticket for you to send the unit in.

Link to comment
Share on other sites

Same boat as everyone else here. Just built a new rig with the same AIO cooler and LCD screen, and tried every suggestion in existence for a fix. This is absolutely absurd this is happening to so many people. I really should have seen this thread before purchasing. How awful is the QA process, or lack thereof for this product? Don't bother creating a ticket; I refuse to send my unit in given how much of a pain it was to assemble. Just wanting to let Corsair know they have a huge gap in QA, and numerous defective software/hardware/firmware complaints. Hoping this new firmware "at the end of March" will fix the missing screen in iCue, but I'm not holding my breath. It's already the 25th.

  • Like 1
Link to comment
Share on other sites

I literally spend a whole 16 hours of my life doing every f***ing solutions that ever existed through Reddit/Youtube/Forums from doing things like back-dating to 4.19 and reinstalling the older block to the new block. Different headers to and using splitters and not using it. To no avail I'm giving up. it's so frustrating how review versions of this product is perfect and runs like butter but here I am wondering where the F is my screen setup...I'm just venting at this point but I already submitted a ticket and please do add me and my brother (We bought two of these s***s). still waiting on a reply from the team.

Link to comment
Share on other sites

Reading all these posts really has me hoping this is just a bad programming error with the software and not the hardware itself. I have read that "some" people have fully functional LCD pump heads and love them but the majority have had nothing but issues from the start. I have a week or so left to return mine for a full refund so I really hope a very smart software engineer at Corsair fixes this in the next few days or I am officially ditching my entire Corsair AIO system and taking my business to EKWB. I have more important things to worry about than having to put up with over $250 worth of computer parts that refuse to work properly. Staring at this "red triangle of death" has really worn my patience thin.

Link to comment
Share on other sites

5 hours ago, TheScarFace85 said:

Over 20 hours of trying to troubleshoot what SHOULD have worked right out of the box. Kit arrived Wednesday, and still as of Today, NO LCD Screen settings in ICUE 4. 

In the same boat as you received it and no settings for the screen just hope with a update I'll fix it

Link to comment
Share on other sites

@Corsair Nicka few of us refuse to send our AIO back for replacement. It’s a headache to disassemble the cooler.
In my country the RMA process is entirely different and if I do give in my AIO it will take weeks or a month for a replacement, so that’s a no from me. As I require my AIO for daily usage. 
I request you to give an update regarding the firmware fix for the commander and AIO asap. 
Thanks!

  • Like 2
Link to comment
Share on other sites

so what im seeing from monitoring this feed is its a hardware problem not a firmware problem because every reply from @Corsair Nick is that we have to send our unit in for evaluation when the unit stays sold out and we may not even get out unit back for weeks because of the volume of people having this issue with the lcd screen which should be a firmware update but i guess defective units made it past quality control, i still love corsair but man this is disheartening. i got my cooler at the beginning of march and people have been dealing with this since its release please corsair dont let us down. try to get a estimate on either a replacement unit for people or the firmware update we dont want to just hear that a ticket was created for us we want answers for out product we paid money for and trusted what we were getting was worth it and going to work.

Link to comment
Share on other sites

3 hours ago, NootZ said:

so what im seeing from monitoring this feed is its a hardware problem not a firmware problem because every reply from @Corsair Nick is that we have to send our unit in for evaluation when the unit stays sold out and we may not even get out unit back for weeks because of the volume of people having this issue with the lcd screen which should be a firmware update but i guess defective units made it past quality control, i still love corsair but man this is disheartening. i got my cooler at the beginning of march and people have been dealing with this since its release please corsair dont let us down. try to get a estimate on either a replacement unit for people or the firmware update we dont want to just hear that a ticket was created for us we want answers for out product we paid money for and trusted what we were getting was worth it and going to work.

Except there are people on their second and third replacements still experiencing the issues, and other people who had a unit that worked absolutely fine initially but then an iCUE upgrade broke it. It seems to me more like they have no idea what the issue is and are throwing new hardware at the wall to give themselves more time to work out what the hell is going on. Obviously I may be completely wrong but there's very little in the way of answers anywhere to be found, just lots of people with brand new hardware that doesn't function.

Windows detects my LCD Cap in the Devices list just fine, it's ICUE that can't find it.

Link to comment
Share on other sites

20 hours ago, Corsair Nick said:

 

Thank you for responding that you're experiencing the same/similar behavior.  I've created a ticket for you to send the unit in.

 

Hey Nick, I have had 2 tickets open for over a week without any word back. If you make a ticket will it be just as useless or do you have some pull? I'm prolly just gonna buy some other new cooler, and when I get a new one from this stupid RMA process Ill just pawn it off on someone else. Same thing with all my broken RGB fans I bought less than 6 months ago. Great products yall make.

Link to comment
Share on other sites

  • Administrators
4 hours ago, Grift3r said:

I have had 2 tickets open for over a week without any word back.

The only recent ticket you have that hasn't been responded to was a duplicate. They last responded yesterday afternoon. Please log into the support portal if you're hot seeing the email responses in your mailbox.

Link to comment
Share on other sites

So I believe my issue is number 2 on the thread but my lcd also has the red triangle. I have tried literally everything everyone has told me I have even emailed Corsair support and in the end they told me to come to this thread. I tried to do the temporary fix and bought and adapter so I could plug in the lcd to the back of the motherboard USB port and it still doesn’t work at all. Do you think this could just be a software problem like nick is saying or a hardware problem and if it is a software problem does anyone know when the update is coming out to fix this? It says it’s coming out late March but it’s already the 26th. I just upgraded my pc and it only worked for maybe 4-5 days then started giving me problems. It’s kinda getting annoying that it doesn’t work. And I’m not sure if this is the same problem but it kinda sucks at cooking my cpu down. I was just watching YouTube with one chrome tab open and my icue open and my fans for the radiator shot up to 1,900 rpm and my cpu was up to 70 c at one point. And my gpu was only at 40-50c 

Link to comment
Share on other sites

Just installed mine today. I have issue #2. It's currently late march, hoping it will be updated in the next few days. At least I am getting a display, but it's stuck on the liquid temp screen. Looks nice, but I'd really like to customize it.

MB: Asus Z690-A D4
CPU: i9-12900k
GPU: Strix 3080
RAM: Vengeance LPX DDR4-3200 4x8GB

Link to comment
Share on other sites

So just an update. As frustrated as I have been with the LCD upgrade kit not working as advertise out of the box, I ordered the complete H100i Elite Capellix LCD AIO from Amazon last night and it arrived this morning. I thought to myself, heck if it doesn’t work I can send it back since Amazon offers hassle-free “free returns”. 
 

The LCD from that bundle had no issues being recognized in ICUE 4. The downside is, I’m left stuck with the radiator, fans, etc that I did not need. 
 

I cannot say for sure if this is a hardware or firmware issue with these units, but regardless, this was an absolutely unnecessary hassle to get this to work. I’m skeptical of any new corsair products from here on out. 

Link to comment
Share on other sites

11 hours ago, TheScarFace85 said:

So just an update. As frustrated as I have been with the LCD upgrade kit not working as advertise out of the box, I ordered the complete H100i Elite Capellix LCD AIO from Amazon last night and it arrived this morning. I thought to myself, heck if it doesn’t work I can send it back since Amazon offers hassle-free “free returns”. 
 

The LCD from that bundle had no issues being recognized in ICUE 4. The downside is, I’m left stuck with the radiator, fans, etc that I did not need. 
 

I cannot say for sure if this is a hardware or firmware issue with these units, but regardless, this was an absolutely unnecessary hassle to get this to work. I’m skeptical of any new corsair products from here on out. 

That's interesting.

Link to comment
Share on other sites

8 hours ago, evanprobin said:

I Have had the h150I elite Capellix LCD since december and it has worked a couple of times. I can confirm this is not just an upgrade kit issue as i do not have the upgrade kit. 

So yours doesn't work sometimes or it no longer shows the screen tab?

Link to comment
Share on other sites

4 hours ago, Zalupa said:

The fix been released yet or are we still waiting...

Many of us are still waiting however it sounds like Corsair are also opening tickets for folks and having them ship their kits back in.

Link to comment
Share on other sites

It makes absolutely no sense that we would have to ship the entire unit back when it's an issue of the software not communicating with the hardware, hence the firmware (for the issue of the screen not showing up in the iCue software. My LCD screen just displays the liquid temperature and the ring light is present, but the screen is not found by iCue after trying every available "fix"). The heatsink is still functioning to cool the cpu, so if that was not functioning properly (even with the thermal paste and all), then yes it would make sense to ship the unit back as it would be defective for its main purpose. This should really be a firmware fix. It's now the 28th of March. What is the status or ETR for the release now if it's not going to be available by the end of this month? We all bought this thing for almost $300 basically for the LCD screen gimmick alone, which doesn't even work.

  • Like 1
Link to comment
Share on other sites

So yeah, where are we with this? I just got my LCD upgrade kit last week from Corsair even though this issue has been known about that before then apparently. I can wait a little but I don't want to be stuck with a product that is past its return policy that was known defective (by software) before it was shipped to me.

Question for those who got the AIO w/ LCD in box, is the pump/bloc and LCD all one piece or do you have to plug in the LCD screen after mounting pump/block? two separate USB (one screen, one controller) or one USB for all of it? 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...