Jump to content
Corsair Community

H150i ELITE CAPELLIX blinking red, saying Device Unknown and only working on random occasions


Recommended Posts

Hello, I'm having a really frustrating experience with my newly-built pc.

Whenever I start the computer all fans immediately speed up to 100% and the H150i Elite Capellix starts blinking red.
This happens even before POST.

In Windows, iCUE then displays an error, "Device Unknown".
 

Relevant System Info:
Asrock B550 Steel Legend (most recent BIOS)
Ryzen 5 5600X
iCUE H150i Elite Capellix
Commander Core (The one that came with the H150i Elite Capellix)

The Commander Core directly connected with the PSU SATA cable, as well as a 860 Evo. 

Firmware is on Version 2.6.201

Didn't have any issues on the first few boots, when the system was freshly built, so maybe it's because of the firmware update I did at some point..?

 

I have already tried the following things:

  • Removing all software that could interfere with iCUE
  • Uninstalling and Reinstalling iCUE
  • Repairing iCUE
  • Moving Commander Core USB connector to a different header or reconnecting it to the same header (->Only lead to the Device Unknown Message appearing again)
  • Disabling C-States in BIOS
  • Force Refreshing the Elite Capellix (What to do when your Elite Capellix liquid CPU cooler is not detected by iCUE)

 

I also tried unplugging the AIO from the Commander Core before turning the computer on and then immediately plugging it in again.
Oddly this does not result in the red blinking and fan problems but instead leads to the Commander Core being shown in iCUE (Instead of the AIO), with all sensors working, and giving me the ability to control all fans. Controls for the pump don't show up and the AIO itself doesn't light up at all.

There have also been two random cases of everything working perfectly fine after a restart, with no detectable pattern. 

Device Manager does not show any corsair-related item. Even when everything is working perfectly fine. Although the Commander Core does turn up under "Bluetooth and other Devices" in the system settings as "CORSAIR iCUE Commander CORE".

Once everything is working at all, it will keep its "everything is perfectly fine"-state if I restart it from the OS, but won't if I shut it down completely and then start it manually.

 

Link to comment
Share on other sites

 

Link to comment
Share on other sites

So does that mean I'll have to wait for the Firmware update? ^^

Link to comment
Share on other sites

I have some corrections to make:

Corsair "composite virtual input device" does show up in Device Manager, regardless of if things are currently working or not!

Also, for anyone who's having similar problems, I have found a fix that needs to be gone through at every startup:
I disconnect the h150i from the Commander Core before pressing the start button on my computer. Then right after starting it (doesn't matter if I do it during POST or when booted into windows) I plug the h150i back into the commander core. Then once I'm in iCUE on Windows, I force update the Commander Core. Once the update is through, everything is working perfectly fine without any issues at all.

Still a super annoying problem with a fix that's quite the hassle.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...