Jump to content
Corsair Community

Corsair Virtuoso Dongle Problems


Recommended Posts

Hello, I bought a Corsair Virtuoso Wireless headset not too long ago and it has been great up until about a week ago. When using the dongle in wireless mode, the volume is glitched and will not change. It is stuck at 100% volume no matter what I do, which as you can imagine, is not too fun. I have troubleshot my audio using Windows 10, reset my audio drivers, updated my USB ports, uninstalled the Corsair iCUE Software, nuked my operating system, nuked my entire computer, etc. I have tried it all. All my other USB ports on my computer are having the same problem when using the dongle. It glitches back to 100% volume instantly, and there is no way to lower it. It's stuck. I have tried literally everything in my power to fix the problem and still nothing... My other wireless headset that uses a dongle works completely fine in all of my computers USB ports, however it is lower quality and I would like to continue using my Virtuosos. However, all this being said, using the headset in it's wired mode using the charging USB cable gives me control of the volume again, and it works perfectly fine. I would normally be fine with this, but I play on a large screen in my living room and sit far enough away from my computer that the USB charging cable is not long enough, and I bought this headset specifically for $179.99 USD for the wireless feature. Any help is appreciated, thanks.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...