Jump to content
Corsair Community

H150i Elite LCD not recognized by iCUE


Recommended Posts

Hi,

I just got and installed my new H150i Elite LCD and I thought that it was working fine till I tried to open iCUE

When opening iCUE the AIO is recognised but within 2-5 seconds it disappears. Sometimes however, it will open then request for a firmware update but then will either disappear or fail (sometimes resulting in iCUE closing randomly)

One major problem I'm facing now is the fans aren't spinning (sometimes they come on but not always)

I've tried switching the USB, completely uninstalling and reinstalling iCUE (deleting all files and regedit files), repairing iCUE, removing the CORSAIR iCUE Commander Core device from devices in settings. Pretty much everything I could find online.

If anyone could help me that would be amazing.

Link to comment
Share on other sites

Here's a video of the issue: 

The software seems to crash randomly after a while too.

Link to comment
Share on other sites

Salut, 

 

Tu l'as branché sur le câble en Y fourni avec le WC ou en direct sur la carte mère ? 

J'avais eu un problème similaire, mais en le branchant en direct sur la carte mère, le problème s'est résolu. 

Bon courage. 

Link to comment
Share on other sites

I've tried both and unfortunately there's been no difference 😞

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...