Jump to content
Corsair Community

My System is not recognizing all Ram

Recommended Posts

My System

Gigabyte GA-K8NS

Athatlon 64 3000+

2 Sticks of VS512MB400

1 Stick of VS1GB400C3


I have run the 2 sticks of 512 for 6months now with no issues. Recently I added the 1gb stick to my system. For first couple of days, everything worked fine system recognized 2gb of memory. Then after that I noticed the bios and windows said I only had 1gb installed. I have tried moving sticks around, and removing sticks. I found out that one stick of 512 seems to be causeing this problem. If that stick is in the system along with the 1gb stick my bios shows 512mb of ram. If that particular stick of 512 is out of the system and I replace it with the other stick of 512 (along with the 1gb stick), my bios shows 1.5gb like it should. The other interesting thing is that even though my bios and windows shows only 1gb of ram, CPU-Z shows me having 2gb.

Long story short....

1gb+512a+512b = 1gb

1gb+512a = 512

1gb+512b =1.5gb

512a+512b =1gb


*note, I also noticed that my 2 sticks of 512 are not exactly the same. Has model number VS512MB400, and the other is VS512MB400C3

Link to comment
Share on other sites

  • Corsair Employees
By putting 3 memory modules on your GA-K8NS MB, you are just hurting the performance of your system, since this MB will only run DOUBLE SIDED memory modules at the speed of DDR200 (PC1600), and no memory manufacturer makes SINGLE SIDED modules in a 512MB or above chips and even if this is possible the system will only run it at a DDR333 (PC2700) speed due to memory controller limiation that is built on the Athlon 64 socket 754 chips.
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...