Jump to content
Corsair Community

Void RGB elite wireless headset will not turn off when pressing power button


Recommended Posts

Hello,

My boyfriend bought me the Void rgb elite wireless headset during the last holidays and I recently encountered an issue where the headset will remain on when I try to power it off. 

To try to troubleshoot it, I looked at the forum and some threads mentioned to force a firmware update, which I did but afterward it wouldn't turn on. I thought that maybe it had ran out of battery due to being on for a while before I tried the firmware update, so I left it plugged for a few days and used my old wired headset. After a few days of checking once in a while if it was powering on, I tried to force another firmware update and now the headset is on, but will not power off again... and it doesn't play any audio aside from the voice prompts (that I enabled to have a better idea of what's going on). This is a bit frustrating, as I bought that headset in replacement of another wireless one with which I had many troubles too. 

Any ideas?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...