Jump to content
Corsair Community

Unable to even install iCue - Installer Crash


Recommended Posts

Hi

I have an AMD system with a Ryzen 2600X and a Aorus B450 M motherboard.
Running the icue4 installer freshly downloaded from the corsair website results in an immediate crash right after pressing "next" for the first time (ie it opens, asks to select language which is on english, hit next, straight crash to desktop) with zero errors or other notifications as to why it even crashed.

I've tried updating everything on the PC (Windows 10, Mobo Bios, Mobo drivers, i tried selecting PCI-e Gen3), it still crashes at the same point every time. 
I tried running as admin also.

I'm at a loss, what do i even do now? Does anyone have any direction or steps i could possibly take?

The only hardware i have is a Corsair Spec Omega case with a Core controller and a couple fans aswell as some perhiperals (Mount, K70 keyboard and some brand new Virtuoso headphones).

Cheers all!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...