Jump to content
Corsair Community

iCUE Disconnects all USB Devices


Recommended Posts

PLEASE HELP! I am encountering an issue with iCUE. I installed one because I wanted to see the battery status of my Void RGB Elite Series, but 5 mins or so, it disconnects all of the usb devices connected to my Laptop!
I have a K70 LUX, red LED only, and m700 mouse pad along with the aforementioned headset I dont need the rgb config, since I use SignalRGB (because my mouse is from logitech, lol) For My laptop, I'm using a Laptop with I5-10300H and 3060 6gb gpu I have 16gb ram, and alot of ssd memory left in my system I work as a Techsupport Agent, so I know how to maintain my system. But I'm not very good, so maybe I still missed something
I have tried everything I can think of!
  • Disabling usb in power management
  • installing an older version of the software (the latest one is 4.20.169, I also tried v3.38.88 for legacy devices, and previous versions up to 4.10)
  • deleting saved info when uninstalling, then reinstalling
  • uninstalling signalrgb to make sure it's the only software that controls the hardware
  • checking drivers for USB
  • disabled allow this computer to turn off usb 3.0 in device manager settings
I cannot think of anything else. Uninstalling instantly fixes the issue and reinstalling brings it back. I am 100% confident that iCUE alone is doing this PLEASE HELP ME!!! I just want to know the battery status of my headset!!! 😞
Link to comment
Share on other sites

  • 1 month later...

Hi,

did you find a solution to this problem?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...