Jump to content
Corsair Community

Virtuoso not working with ICUE4


Recommended Posts

After owning these for 3 weeks and trying ALL the reddit and form suggestions to get my headset to show up on ICUE4. It does simply not work. Don't suggest anything about resetting the headset / re installing the software / repairing the software. I've tried it on multiple Windows and Mac computers. same problem. 

What can I do? 

 

Link to comment
Share on other sites

  • Corsair Employees

Hi

Reset the Virtuoso,

To soft reset your headset make sure your mic is plugged in:

1. Make sure your headset is currently unplugged.

2. Make sure your headset is powered on.

3. Hold the Mute button on the headset down for about 15 seconds.

4. Switch the headset to wired mode and then back to wireless mode.

Let me know if this helps with your issues.

Link to comment
Share on other sites

Hi, if you read my previous post, you'll see that that reset has bee attempted by me, i've tried it 7 times to be precise. 

Please help me diagnose the problem in some other way, My refund period ends next week, I will be returning the headset if not resolved by then as they do not work as specified.

Regards

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...