Jump to content
Corsair Community

h100i Elite disappears from iCUE after a few minutes


Recommended Posts

Hello Corsair forums!

My specs:
CPU: AMD Ryzen 7 5800X 3.8 GHz 8-Core Processor 
CPU Cooler: Corsair iCUE H100i ELITE CAPELLIX 75 CFM Liquid CPU Cooler 
Motherboard: MSI B450 TOMAHAWK ATX AM4 Motherboard 
Memory: Corsair Vengeance RGB Pro 32 GB (2 x 16 GB) DDR4-3200 CL16 Memory 
Storage: Samsung 850 EVO-Series 120 GB 2.5" Solid State Drive 
Storage: Samsung 870 Evo 500 GB 2.5" Solid State Drive 
Storage: Samsung 970 Evo Plus 1 TB M.2-2280 NVME Solid State Drive 
Video Card: Gigabyte GeForce RTX 3070 8 GB EAGLE OC Video Card 
Case: Fractal Design Define R6 ATX Mid Tower Case 


The issue I'm having with the cooler, is after about 2-3 mins, regardless of what I'm doing on the PC, the Cooler and the fans will default back to default colors, and the H100i will fully disappear from iCUE software. To get it back, I either have to restart my desktop, remove the Commander Core from my devices, and search for hardware changes in Device manager, or unplug/replug the USB header to the Commander core. At first I thought something was amiss with my windows install, so I wiped my C drive, and reinstalled it, no dice. Attempted to reinstall iCUE 3 times no, still no dice. Checked all connections, attempted both of my USB headers on my mobo, still no dice. 

Where it gets even more weird, is when I attempted to use iCUE 3.x software, the cooler was recognized and not once disconnected from the software, yet I'm not able to change any settings on it until I update the firmware. It'll let me update it, but still not able to do anything as it's still a version or so behind. The twist is when I went to go back to iCUE 4.x software, the cooler did not disconnect once... until after the update was pushed through which is forced upon the user. 

I'm a bit at my wits end with this cooler and brand, I have a keyboard and mouse from Corsair, and they work well when iCUE decides to want to work. 

Link to comment
Share on other sites

Hi!

Here having the same issue with H100I ELITE CAPELLIX.

Randomly disconnects between 2 - 3 sec from iCUE and sound like USB disconnecting on Windows. I look at my PC when this occurs and all the lights went OFF like this video: 

Can someone from support help us with this problem?

Thank you very much and greetings

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...