Jump to content
Corsair Community

iCUE Profiles not working on K70 MK2 SE keyboard while iCUE isn't running....


Recommended Posts

Hi everybody! 

I own a Corsair K70 MK2 SE keyboard and lately I have been having trouble with iCUE. To preface this, I USE A MAC. I have had my keyboard for about a year now and it has worked great! But I recently upgraded to the latest version of iCUE (as of Feb 2022) because my Mac was having lots of trouble running it previously. I decided to play around with some new lighting effects for my keyboard so I cleared the memory and made new profiles but even AFTER saving the new profiles to the slots, my keyboard won't light up unless iCUE is running... any ideas? I have done a soft reset of the keyboard itself and tried deleting and reloading the profiles and resaving them several times but nothing seems to work! My arrow keys aren't working at all either... Please Help!  

 

Thanks, 

Mia :)

Link to comment
Share on other sites

are you on an M1 Mac or Intel? I am on M1 and notice that the keyboard lights up, but if iCue is not on, it just gives a standard rainbow pattern. iCue crashes consistently for me, lasting maybe 20 mins at a time (max).

Link to comment
Share on other sites

Hi Samstrat, thank you for replying to my post - I have an Intel Mac and unfortunately iCue still crashes for me if I try and reset my profiles and resave them. This is annoying because the keyboard has on board memory so I should be able to quit iCue and still have the lights running. Not really sure what to try next.... 

  • Like 1
Link to comment
Share on other sites

  • Corsair Employees

Can you provide some screenshots of the iCUE window with the effects you are saving to the onboard profiles?

Link to comment
Share on other sites

On 2/7/2022 at 5:01 AM, mia74 said:

Hi Samstrat, thank you for replying to my post - I have an Intel Mac and unfortunately iCue still crashes for me if I try and reset my profiles and resave them. This is annoying because the keyboard has on board memory so I should be able to quit iCue and still have the lights running. Not really sure what to try next.... 

Same, intel MBA Monterey 12.3, iCue 4.20.169 locks up multiple times a day and I can save profiles to my Dark Core mouse, but can neither clear the profiles or save them for my K70.  I can't delete them directly either, and overwrite appears to try to do something, but doesn't in fact save and/or hangs at the saving dialogue and never completes.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...