Jump to content
Corsair Community

Dominator RGB DDR5 vs Asus ProArt Creator Wifi z690 compatibility?


Recommended Posts

After much hair pulling and severe bank account depletion, I assembled what I had hoped to be my last system after my last workhorse died after 12 years of 24/7 intense use.  It was an Intel DX58SO with an older, once higher end, i9.

So, I went all out and ordered, then received and assembled the following:

MB: Asus ProArt Creator Wifi z690 Intel platform
CPU: Intel i9-12900K
CPU Fan: Noctua NH-U12S (Chroma.Black)
RAM: 64GB of 2x Dominator RGB DDR5 32GB kits (2x16GB ea)
Disk: 2x FireCuda 2TB M.2 sticks (for their high speed and very high TBWs)
PSU: EVGA 1000w Gold+ 10yr

Assembled and began naked testing on work bench.
After figuring how to turn it on via jumper shorting, was elated at Dominator's RGB DDR5 light show.
Alas, according to MB lights, boot process hangs at the 2nd of 4 boot stages (DIMM check)
I began removing/swapping Dominator DDR5 sticks
Also used different slots.
Tried 4, then 2, then 1 stick in various slot combinations.
Results were unchanged. Though RGB lights behave as expected, motherboard boot progress LEDs always stop at DIMMs.

Anyone know of any incompatibility between this Asus MoBo and 64GB of Dominator RGB DDR5 sticks (4x16GB ea)?

Since it never passes DIMM check, I cannot do or see anything.
Can't even get to using BIOS etc with memory failing test

Since I paid a fortune due to supply chain issues whilst needing this system to go live yesterday for taxes, Bills, and media projects that are overdue, I'm at a total loss as to what to do.

Any/all help would be greatly appreciated.

XOR42

Link to comment
Share on other sites

Re my previous post about "Asus z690 ProArt Creator Wi-Fi" MoBo vs Dominator DDR5 memory:

The exact memory model is as follows:

CORSAIR Dominator Platinum RGB DDR5 32GB (2x16GB) DDR5 5200 (PC5-41600) C40 1.25V - Black

I've since found that it is not on the Asus approved list for that MoBo.
That could mean they tested it and rejected it, or they simply haven't tested it yet.

Thanks, in advance.

 

Link to comment
Share on other sites

  • 3 months later...

Did you ever manage to get this sorted? I ask because I have the exact same problem. In my case it is 2x32GB for the Dominator Platinum but everything appears to switch on without a problem, including all the lights, but then the whole thing stops with the amber (DRAM) QLED lit. I have tried upgrading the BIOS to the latest version and taking everything out except processor and memory but always with the same result.

Thanks.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...