Jump to content
Corsair Community

Odd Profile and Windows Key issue


Recommended Posts

Howdy all, I have the following:

M65 RGB Elite mouse

MM600 Mouse mat

K95 RGB Platinum keyboard

iCue Nexus screen

3 SP140 RGB Pro Performance fans

3 RGB Lighting Pro LED strips

Commander Pro

Lighting Node Core

Vengeance RGB Pro mem (64GB 2933 DDR4)

H100X CPU cooler

HX1200 PSU

750D Obsidian Airflow Edition case

 

 

Here is my issue:

I have a series of iCue profiles, mainly to do with lighting (Blue, Red, Green, White, Spiral Rainbow lighting links) and some custom K95 key mappings (Gkeys and App button lockout) - along with the usual that are included (profile switch/win key lockout/brightness control buttons). My issue is that when I have my Green iCue profile activated (3rd down in the list and NOT the default), and the Win key lockout button disabled - when I press either Win key, the Blue iCue profile activates (this is the default profile). This does not happen on any other profile, and I've even made this Green profile from scratch (did not fix it) thus I reinstalled iCue completely from scratch and remade each profile (did not fix it).

Any ideas?

Edited by ArgonV
Updating problem details
Link to comment
Share on other sites

P.S. All of this is running on the latest iCue release (as of yesterday) on Win 10 Pro 20H2.

Link to comment
Share on other sites

P.P.S. I made another profile the default one - and now when I activate the Green profile, press the unlock Win key button then press the Win key - the profile switches to that new one.

I will also add that my Green profile is the only profile where I have it set to activate upon launching some games. Might this be the cause?

Link to comment
Share on other sites

I think what’s happening here is the “green” profile is assigned to Application X and that makes it exclusive to that application. When you hit the Win key the desktop becomes in the in focus application and so it transitions back to the default profile, until you return focus to the linked application. 
 

Possible solutions are to disable the Win key in the green profile (if this accidental like in game) or if you need to use this profile while on the desktop, create a copy of it. In Green 2 (or whatever you want to name the copy) delete the program link. It will now function like a normal profile and CUE will still auto switch to its twin when the app is in focus. 

Link to comment
Share on other sites

Thanks, I'll try that and see if it works. I have many game programs linked - they are all flight sims, I have many USB controller devices whose buttons are green backlit and wanted to give the look and feel of it being a homogeneous cockpit.

Link to comment
Share on other sites

OK, disabling the Win key in the game specific profile may be the best path.  Pretty common to accidentally hit it when going for the neighboring buttons.  This is one of the quirks of using linked programs and there are a few things like this.  Any profile that is designated for a specific .exe will no longer function as a normal profile, can't be the default profile, etc.  

Link to comment
Share on other sites

That worked, cheers! It will still go back to my default profile if I need to hit the Win key in-game using that profile, but that happens very rarely and so I usually have the lock button On. Tho at times I like to have it in the Green profile on my desktop, so this a good compromise.

Edited by ArgonV
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...