Jump to content
Corsair Community

Corsair Vengeance RGB PRO 32GB (2 x 16GB) PC4-25600 (DDR4-3200) not recognized on motherboard


Recommended Posts

Issue: Fans are spinning colors are changing. Light is on the motherboard indicating that the CPU is talking to the motherboard. Other 3 lights do not turn on (DRAM, VGA, Boot). I can get my PC to POST with my new Corsair Vengeance RGB PRO 32GB (2 x 16GB) PC4-25600 (DDR4-3200); CMW32GX4M2Z3200C16

My build:
1. Corsair 4000x ICUE rgb case
2. Gigabyte: B450 I AORUS PRO WIFI (rev. 1.0) motherboard (AM4 Format)
3. AMD Ryzen 5 5600x with include Wrath cooling fan
4. RAM: Corsair Vengeance RGB PRO 32GB (2 x 16GB) PC4-25600 (DDR4-3200) in motherboard DDR slots 2 & 4.
5. Graphics card: MSI Radeon R9 280 in first pcie x16 slot
6. PSU: Corsair CX550F RGB, 550 Watt, 80 PLUS Bronze, Fully Modular RGB Power Supply
7. SSD: Samsung 850 EVO 250gb: in the Sata3 slot 2 (0, 1, 2, 3 are my options)
8. Monitor: Dell UZ2315H (resolution 1920x1080)

 

Any reason why I can't get to the Post screen on my monitor?
Things I have tried:
1. Move the DDR memory to slots 1/2
2. Removed the CMOS and put back after 10 mins.
3. Removed Graphics card and plug into the hdmi slot on the motherboard.
4. Removed the SSD
5. Downloaded Windows on a USB drive hoping to boot off of it.

Link to comment
Share on other sites

everything sounds ok.  are all the the components brand new?

so you don't even get into the bios?   did you re check all the cables?

is the cooler mounted properly?

maybe try just one memory stick in different slots.

does the motherboard have a post status error display (like asus)? it should show what's wrong

with an error code or sounds...    

i see there is a bios update for supporting ryzen 5xxx series.   is the actual bios ready for your cpu?

Edited by zultan
Link to comment
Share on other sites

Bios doesn't even make the monitor.  I have it plugged into the HDMI from the board to monitor.  I also put in an old Graphics card to see if it would boot up.

Besides the Graphics card everything else is new. I took it back out and same issue.

Attached are screen shots of the lights that are check upon turning the computer on.  Only the DRAM light lights up.

Which it means its the DDR Card.  I went to Gigabyte website and looked up my motherboard and looked at the approved DDR4 for that drive and mine is not on the list.  I just bought one on Amazon and that was on the list.  I will let you know what happens when it arrives.

they are the same in every way 1.35v rgb 3200 DDR4.  It's not a Corsair. It's a Crucial Ballistix 1.35v 3200 DDR4.

 

We'll see if that does the trick. 

 

 

 

20220203_162717.jpg

20220203_162338.jpg

  • Like 1
Link to comment
Share on other sites

usually even a not listed ram stick should work on a good motherboard.

once I bought some good brand ram for a colleague, (matching the motherboard specifications). he wanted to upgrade an HP desktop.

the ram didn't work but the motherboard was an awful chinese one.

i sold the ram to another colleague and they worked perfectly on an asus board.

I'm not so much into gigabyte products anyway it's a good brand. it would be quite strange that corsair ram are not working.

can't you try the sticks into another pc?  maybe a friend?

Link to comment
Share on other sites

hey hello.   I have found this.   have a look.

I wouldn't exclude a motherboard issue...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...