Jump to content
Corsair Community

ICue 4 in Windows 11


Recommended Posts

Hi Corsair Team, 

I recently upgrade my system from Windows 10 to Windows 11 (free upgrade). I have already installed ICue 4 in my system (when it was still Win 10)  but after the system upgrade to windows 11, the app just crash and it is not found in the app drawer. So I tried to reinstall the latest ICue 4 but it seems I keep getting the annoying BSOD everytime it tries to complete it's install. And so it restart and I have to try and try again. But until now, still no luck. And now all my peripherals are in Rainbow mode. Hope you can resolve my problem.

Thank you in advance.

Link to comment
Share on other sites

You may have some file corruption in the registry from the Win 10->11 conversion. Try a clean install from the directions below and make sure you go to the specified locations to clean out the files. Then reinstall normally. 
 

https://help.corsair.com/hc/en-us/articles/360025166712-Perform-a-clean-reinstallation-of-the-Corsair-Utility-Engine-iCUE-
 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...