Jump to content
Corsair Community

Dark Core RBG Pro not working


Recommended Posts

Hi all, I'm really hoping someone might be able to help. I work from home and losing my only mouse is now cauing me a huge issue as I'm trying to work as I type this. I stupidly updated iCue software to the latest version today on a whim. Everything worked fine, I use corsair everything so needed to do it as the previous version kept crashing and locking up my pc. So my K100, fans, rgb hub all working fine but after updating the dongle firmware to 5.4.99 my mouse disappeared from the list. It won't work wired, wirelessly anything.

 

I have tried to find older firmware to force an update but cannot find anything for this mouse. I've tried factory resetting the mouse with no luck at all, does anyone have an older firmware file or any advice please as I am in dire need of getting this resolved as quickly as possible.

Many thanks.

Link to comment
Share on other sites

Just gonna add an update here for those searching on google.

I was able to resolve this by installing the latest version of iCue onto a different pc, plugging the MOUSE ONLY without the dongle into that pc with a generic usb c cable, it then let me update the firmware, I did this for both wireless and wired modes. When I plugged it back into my pc with the dongle plugged in it picked it up right away.

I hope this helps anyone suffering with the same issue.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...