Jump to content
Corsair Community

DOMINATOR PLATINUM RGB DDR5 ram don`t work with Gigabyte Z690 AORUS MASTER, LGA 1700


Vasilisk_
 Share

Recommended Posts

I assembled a computer, it does not start, it does not display anything on the monitor through the display port. The central processor has a graphics core, I installed a video card, the display is connected through the display port on the motherboard.

  • motherboard: Gigabyte Z690 AORUS MASTER, LGA 1700, Intel Z690, eATX, Ret
  • Processor: Intel Core i9 12900K, LGA 1700, OEM [cm8071504549230s rl4h] (with graphics core)
  • RAM: Corsair DOMINATOR PLATINUM RGB CMT32GX5M2X5600C36 DDR5 - 2x 16GB 5600, DIMM, Ret
  • PSU: Thermaltake Toughpower iRGB Plus, 1050W, 140mm, black, retail [ps-tpi-1050f2fdpe-1]
  • Hard drive: WD Red Pro WD121KFBX, 12TB, HDD, SATA III, 3.5"
  • Cooling system: liquid GIGABYTE AORUS WATERFORCE 280
  • Case: EATX Corsair Crystal Series 680X RGB


In the process of trying to boot, - in the lower right part of the motherboard, of the 4 LEDs that display an error, the top two (CPU and RAM) blink alternately.
In the upper right corner of the motherboard - an alphanumeric indicator on the motherboard gives out a cyclic sequence of codes:
C2
C4
28
4C
54
Several such cycles pass on the indicator and after 1 minute and 10 seconds it stops at the value C1 (memory error).
At this moment, the red RAM error LED is on in the lower right part of the board.
The memory slots are inserted according to the instructions in A2 and B2.
I tried to insert only one of the dims in series into all of the 4 RAM connectors - it did not help. Tried the same with the second dim. It is unlikely that both RAM dims are faulty.

Next is the most unusual

in the motherboard description on this page https://www.gigabyte.com/Motherboard/Z690-AORUS-MASTER-rev-1x/sp#sp
it is indicated that the board supports up to 128GB in total for 4 slots (32GB per slot), verbatim:
"4 x DDR5 DIMM sockets supporting up to 128 GB (32 GB single DIMM capacity) of system memory"

but if you look at the memory support list here https://www.gigabyte.com/Motherboard/Z690-AORUS-MASTER-rev-1x/support#support-memsup then it becomes completely incomprehensible how you can dial 128GB? According to this list, the ceiling is 32GB dialed by 2x2Rx8. Indeed, there is a footnote at the bottom:
"* Memory modules listed as above is for reference only. Due to massive memory models in market, we can only verify some of them."
 


What is it like?
Does the computer really not start due to "incompatibility" with Corsair DOMINATOR PLATINUM RGB CMT32GX5M2X5600C36 DDR5 modules - 2x 16GB 5600, DIMM

Link to comment
Share on other sites

You'll be happy to hear I'm running exactly the same Z690 Aorus Master motherboard with exactly the same memory and it works fine.

You most likely need to update your bios a lot of the Z690 Gigabyte boards shipped with a very early bios, it didn't even have NVME support. Took some hair pulling research to figure that out. After I updated using the process below, everything worked. 

You'll need to download the latest bios onto a USB stick and update via the Q-Flash Plus button on the motherboard back panel. You'll need to rename the BIOS file from it's version specific name to GIGABYTE.BIN as the Q-Flash hardware button process looks for only that filename on the USB stick. 

The instructions are in the mb_manual_z690-features.pdf you can download from the manual section of the Z690 Aorus Master support page. They're on page 6, Section 1-3 Using Q-Flash Plus (I attached the pdf below, you'll still need to go get the latest BIOS file)

Here's a video showing the process, he's doing it for the Z570 Aorus Master, but it's exactly the same process on the Z690 mb.

After flashing, you should use the clear CMOS button on the back panel to reset the BIOS back to default values.

mb_manual_z690-features.pdf

Link to comment
Share on other sites

  • 1 month later...

Build Gigabyte z690 Aoris master. Pins looked good and I was able to flash the board with firmware update F7.  I am using the Corsair Dominator 5200 and I'm still unable to boot my system.  I don't think the error codes provide any validity but after updating I g.et the following codes:  00 C2 C4 12 28 4c 0D 0E 31 2E 54.  This is my third board.  My suspicion falls on the CPU (Core I7-12700K) but over the last 15 years I've not seen a processor fail. Any ideas what the problem might be. I'm not returning anymore equipment until I have the right solution 

Link to comment
Share on other sites

  • 3 weeks later...

I have the same setup as you and have had similar problems. im the end it was a bad memory kit. I would advise that you create a memtest boot disk and test the memory. I had mine replaced and all is fine. error code 54 means the memory cannot train. hope this helps.

Link to comment
Share on other sites

  • 4 months later...

I had the same problem with dominator 6200 and aorus master z690. After bios update it worked.

after new update (think it was f8-d) it started to beeb and giving error 25. Even if i put back old bios the error code stays and beeping also. Works fine in windows but not ingame. Keeps hanging and crashing. 
asked help from gigabyte and they told that they havent tested those rams and inshould buy new ones that jave been tested...

yesterday i added f20-a version and still beeping and giving error 25. Run multiple different memtests and dont show any problem. 
 

Never used gigabyte before... what the dissapointment. Should have stay with asus as before.

asus mb show that their mb support this ram.

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...