Jump to content
Corsair Community

Corsair Harpoon RGB not being registered by ICUE, can be seen in other programs like USB Overdrive


Recommended Posts

Im running the latest version of ICUE, no available updates. I can see the CORSAIR HARPOON RGB device being recognised in other applications but when I run ICUE all I can do is edit profiles, I have no other options than clicking profiles. Im running MacOS Big Sur ver. 11.3.1. I've checked online and the Harpoon is compatible with my ICUE software. Another problem I'm having is that in all games I run if I use the corsair mouse my framerate drops whenever the mouse moves around the screen, however when I use the trackpad instead the game is 60 fps, smooth as a whistle and does not jump, lag or stutter at all. Is this a problem with the drivers? or is the Harpoon just not compatible with MacOS? Thanks.

Link to comment
Share on other sites

Honestly, I think its a bit ridiculous that my stock 2015 macbooks TRACKPAD functions better in games than the mouse which is exclusively made for gaming. Played a round of CS:GO on trackpad and the game ran perfectly smooth, no frame drops or stutters. Plugged in my corsair and the game starts lagging whenever I look around, to the point where I lose almost every gunfight because when I try to look at people my FPS drops from 50 to 5. WHat is going on with this? please help!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...