Jump to content
Corsair Community

QL120 One LED stuck on Green


Recommended Posts

I just bought these QL120s one month ago and they worked very well. But last week, one LED stuck on green. When I turn on my pc, that green led turns on as well before other LEDs. I've tried everything like;

1. switch rgb slot

2. power off pc and unplug for hours

3. reconnect sata

4. end task other rgb software (Dragon Center, RGB Fusion)

5. repair icue software

6. reinstall icue software

but doesn't fix the problem. What should I do?

540183515_greenled.thumb.jpeg.5e9148b1035a05dcbc8de65a4ef5ada4.jpeg1453753484_icueoff.jpeg.039eee23f817ef3a8b2485745cff634b.jpeg

Edited by mhazimbh
adding information
Link to comment
Share on other sites

You probably need a new fan and should contact Corsair Support for the replacement.  You've already done every logical troubleshooting step.  Make sure you include that in your support ticket.  The Commander Core has independent RGB headers unlike most controllers.  If you move the offending fan to another port and the green effect travels with the fan, then it most certainly is a fan problem.  

  • Sad 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...