Jump to content
Corsair Community

Will iCue ever work on M1 Macs?


Recommended Posts

I picked up a Virtuoso RGB headset about a year and a half ago to use with my M1 Mac mini. According to everything on the product page it sounded like just what I wanted. Unfortunately then I downloaded and installed the iCue for Mac software and my headset suddenly had no audio. After some searching, I found this page on corsair's website https://help.corsair.com/hc/en-us/articles/360054555652 which clearly says that iCue doesn't yet work on M1 macs because they're so new but that, "We are currently working on an update to fix this issue." Now 18 months later, I still don't have a working version of iCue. Does anybody know if Corsair is actually even trying to fix this problem? At this point the M1 Macs are hardly a new thing and I'm starting to feel like Corsair doesn't really give a flip. I tried contacting customer service to ask this but they were completely useless so I thought I'd try the community-at-large. I hope somebody out there can help. Thanks!

Link to comment
Share on other sites

  • Corsair Employees

You will need to download and install the latest version of iCUE 4. If you are installing the legacy iCUE 3.38.xx software it will not work.

Link to comment
Share on other sites

  • 3 weeks later...

I am running M1 Max Macbook and have a K70 Keyboard and a Dark Core Wireless Mouse from Corsair. I am running iCue 4.19 (latest I think) and though it runs and recognizes the devices, it crashes consistently after a few minutes (though I've never really timed it). The result is the effects programmed into the keyboard and mouse don't work anymore (just standard rainbow pattern). A computer restart isn't necessary, but you need to run Activity monitor or otherwise force-quit the app and relaunch it. Most times, it works again (until the next crash). I've also noticed it is not M1 Native... while I understand many considerations required to make it native, you do know Apple will stop Rosetta 2 after a maybe one or 2 (max) Mac OS releases like it did last time when switching to Intel.

Link to comment
Share on other sites

  • 3 months later...

I had the same problem. get almost all the way installing and then says contact software provider.

I tried several times but then I had a 2012 MacBook Pro and the same thing happened "BUT" that little Mac said installation is blocked by accessories and told me to make sure it was allowed in accessories and also security. and privacy.

I did that and restarted it and now everything works beautiful

Hope this helps you.

David F

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...