Jump to content
Corsair Community

Corsair K70 LUX not working in Ubuntu 20.04


Recommended Posts

I had reinstalled Ubuntu 20.04. The keyboard and mouse appeared to be working fine through my KVM switch but now they do not. Actually, they work briefly and then fail. I tried plugging directly into the PC and still no luck. Odd thing is I can plug them into my Ubuntu laptop and the work and remain working. The only thing I can think of is that something on this new build is not allowing the keyboard to work. Any ideas?

Link to comment
Share on other sites

  • Corsair Employees

Hi future-vision,

Unfortunately, we don't support/ recommend use of our keyboards on either Linux, or a KVM switch -- we additionally do not recommend using any kind of USB hub or passthrough of any kind. Apologies for the inconvenience. 

Link to comment
Share on other sites

Seems to have a similar issue when plugged directly into the computer. It works for a bit but then the keyboard won't input. USB port on the keyboard continues to work however. 

 

I know. You don't support/recommend using with Linux. Just odd that it worked for so long and now it doesn't. Works on the Linux laptop though.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...