Jump to content
Corsair Community

Corsair Scimitar Elite not saving profiles


Recommended Posts

Hey everyone, so I upgraded to a Scimitar Elite today from a first Gen Scimitar. However When i try to save a profile to the mouse so that I don't have to have iCue running it seems to forget all of my key bindings. I have tried both Corsair iCue 3 and 4 and both programs say they have saved the profile to the mouse however i cant use the key binds when iCue is not running. Its also responding the same way with lighting profiles too. I have so far tried restarting my comp, clearing all saved profiles and resaving the one that I want. Uninstalling and re installing both Icue 3 and 4, both at separate  times. and the good old fastion unplugging it and plugging it back in.

 

My current HW set up is as follows 
CPU: 3900X
Mobo: Asus x570 Strix E
GPU : Asus RTX3080 Strix
Ram 8x4=32 gb 3600MHz CL16
Cooler: Lian Li Galahad 360
Fans: Lian Li Unifan 120mm x6
Storage: 1TB Corsair 510 m.2, 1TB Samsung Evo 860 SSD, Seagate 2TB SSHD
Psu: EVGA 850W Gold G3

Link to comment
Share on other sites

  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...