Jump to content
Corsair Community

iCUE v4 wont run.


Recommended Posts

I have no clue why but after my pc updated to the newest version of windows 10, whenever I try to open iCUE the app starts running along with the processesit uses but then iCUE immediately closes. I've already fully uninstalled and reinstalled it and it still doesn't work. 

Link to comment
Share on other sites

Same thing here. Starts up, prompts "Mic o.." and crashes. Repair install doesn't work (gets stuck). Remove and reinstall doesn't solve the problem either. Any help would be appreciated.

Cheers,

Rab

Link to comment
Share on other sites

Update:

I've removed all devices one by one and tried starting up iCUE again. When I disconnected my Nexus the problem was solved. As soon as I plug in the Nexus again, iCUE crashed again. Also if I plug it in different USB ports.

 

Cheers,

Rab

Link to comment
Share on other sites

  • Corsair Employees
1 hour ago, Rabdalas said:

Update:

I've removed all devices one by one and tried starting up iCUE again. When I disconnected my Nexus the problem was solved. As soon as I plug in the Nexus again, iCUE crashed again. Also if I plug it in different USB ports.

 

Cheers,

Rab

Make sure you update your chipset drivers and your GPU driver.

Link to comment
Share on other sites

20 hours ago, Corsair Notepad said:

Make sure you update your chipset drivers and your GPU driver.

Thank you for your quick reply. They are and were already all the latest versions... (just checked again to be sure).

Cheers,

Rab

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...