Jump to content
Corsair Community

HS70 pro constant static noise!


Recommended Posts

Brand new headset has a constant humming / static noise from left side. Starts and stops exactly when the wifi dongle connects / disconnects. 
 

Have tried all posted solutions with no change. 
 

Retailer tells me no refunds no exchange. 

Link to comment
Share on other sites

  • Corsair Employees

Hi Trevor Cole,

Please go to CONTROL PANEL / HARDWARE AND SOUND / POWER OPTIONS and then click on CHANGE PLAN SETTINGS (for your current default power plan). After that click on CHANGE ADVANCED POWER SETTINGS.

When new window opens, scroll down the list a bit until you hit USB SETTINGS. Click little square with plus in it, and then click another little square with plus next to USB SELECTIVE SUSPEND SETTING. Check the state of it, and make sure it's set to DISABLED.

See if that makes any difference. Hope this helps.

Link to comment
Share on other sites

same issue tried your fix.

I have seen another suggestion that your internet WIFI signal is causing the issue, I find that that may well be the case as I do not get this issue when further away from my modem(down the hall) but the problem is severe when right next to my modem. 

the suggestion is to limit the range of frequency your modem transmits, but that is not something I can do comfortably

 

Link to comment
Share on other sites

  • Corsair Employees

If you have the option to switch to a 5GHz band instead of the 2.5Ghz, that will help a ton as well. All our wireless devices (and additionally, anything Bluetooth by any manufacturer) runs on the 2.4Ghz band, which unfortunately can result in congestion issues such as this. 

Link to comment
Share on other sites

On 1/11/2022 at 4:21 PM, Corsair Blade said:

Hi Trevor Cole,

Please go to CONTROL PANEL / HARDWARE AND SOUND / POWER OPTIONS and then click on CHANGE PLAN SETTINGS (for your current default power plan). After that click on CHANGE ADVANCED POWER SETTINGS.

When new window opens, scroll down the list a bit until you hit USB SETTINGS. Click little square with plus in it, and then click another little square with plus next to USB SELECTIVE SUSPEND SETTING. Check the state of it, and make sure it's set to DISABLED.

See if that makes any difference. Hope this helps.

Hello, thank you for the response. Both of your suggestions I had not come across yet. 

Unfortunately, even after making sure the USB selective setting is DISABLED and switching all available devices to 5GHz the noise is still present. 

I am worried that there is a wire missing insulation or with a bad connection but do not want to open the headset and void warranty. 

Please let me know if there is something else I can try. I was tempted to upgrade to the HS80 but is it likely all of your wireless headsets have this problem?

Link to comment
Share on other sites

  • 4 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...