Jump to content
Corsair Community

New Corsair Virtuoso XT has a weird noise whenever I turn on wireless mode.


Recommended Posts

So I've bought the Virtuoso XT.

It came here today and I was really hyped.
And I still am.
I immediately used the slipstream wireless connection to pair it with my PC. It was... Fine? It has a very silent weird noice. Sound is good but there is a little bit of noice. I can't hear it if I watch videos or play games or whatever.
So that's really fine.
Problem is: i can't activate surround sound.
Which is sad, and I thought it might fix the weird sound.
But I can't even activate it.
So in the end I tried to connect it with the USB C connection as well.
Just to have it connected (a lot of features of my dark core RGB pro SE need wired connection so I figured it might help).
And the weird noice was now a louder very annoying noice.
So I tried a lot of stuff.
I reinstalled iCUE but kept my profiles. I clean reinstalled iCUE and deleted every single folder on my PC, I tried it in a lot of different combinations.

3.5mm was good.
3.5mm with USB C was good.

Bluetooth was good... Kind of. It had the silent weird sound.
Bluetooth while charging was good.
Bluetooth with 3.5mm was good.

Slipstream had the silent noice.
Slipstream with Bluetooth had... Well. The more silent noice I could live with (but would prefer not to) but that's just because of the slipstream itself.
Slipstream with 3.5mm was not something I tried.

USB C alone was good.
It's only the Slipstream while charging config that makes a really bad noice. I don't know how to describe it. Kinda like a high pitched PC fan.

Then I've learned that the Virtuoso XT is not supposed to have it's 7.1 sound turned on in iCUE. It uses the Dolby app instead. So I installed it. And its fine, but it didn't fix the sound issue.

On top of that. If I use the Dolby Atmos app, windows uses the 2 channel, 24 Bit, 48000Hz.
And if i don't use it my headset uses the 8 channel, 24 Bit, 48000Hz setting in windows.
Don't know why that is. But it is what it is. Don't even know what that means but I thought it might be worth mentioning.

I just tried it with a different PC, one without iCUE, it never had it installed. And it's the same issue.
Even if i charge my headset with the USB C cable using a powerbank, it still has that annoying sound.

But for me it doesn't feel like a hardware issue. Because I can do every combination of things I can imagine. But I just can't go with slipstream while charging.
But iCUE can't be the issue here I think because I clean reinstalled it as well.
I even forced an firmware update to my slipstream reciever and my headset. And it didn't change anything.
But my knowledge about sound is VERY limited. So I hope I can find someone that is able to help me here.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...