Jump to content
Corsair Community

Corsair Harpoon Side Button Not Working


Recommended Posts

Hey there, I was using my Harpoon RGB for about 1 year plus until now. Recently, my side button (button 6) was not functioning propoerly neither in game or in webpage mode.

What had I done after the issue appeared :  

  1. I didn't use iCUE, recently download it just to update my mice fireware (thought it might be somekind of bug or what), but it didn't help at all
  2. I tried to reset my Mouse Setting, still not working

Does anyone met this issue before? Thanks for the help


 

Link to comment
Share on other sites

  • Corsair Employees

If a clean reinstall of iCUE does not resolve the issue, try repairing iCUE.

Before repairing iCUE, delete the “Corsair composite virtual input device” driver.

Open Device Manager.
Select Human Interface Devices.
Right-click Corsair composite virtual input device and select Uninstall device.
Tick the Delete the driver software for this device checkbox, and then click Uninstall.


Delete_driver_checkbox.png
 

Rerun the installation file for iCUE and select Repair.
(iCUE 3)
icue_installation_repair_option.png
(iCUE4)
mceclip1.png

 

Follow the instructions for repairing iCUE.
Reboot your PC.

Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...