Jump to content
Corsair Community

Elite LCD Display error


Recommended Posts

Hello and happy new year ! 
I just got an upgrade kit for my Elite capellix and installed it . I had already installed the latest update before installing it .

As I turned my pc on , I got an exclamation mark on the lcd display and my pc didn’t boot , the fans went crazy and I got an cpu fan error . 
I got scared , I searched a bit , finally I selected “ignore cpu fan speed “ in the bios menu , my pc then booted but I couldn’t find my lcd in the icue. My windows did detect my lcd capellix thought ! 
So ..I just installed the old led capellix , but the led didn’t light on , and was also not in the icue . 
Now I have two things that don’t work.. any ideas ? 

Pc specs : AMD Ryzen 1900 , Asus Prime X370 pro , Radeon RX 570 , 16GB Vengeance rgb pro , H150i Elite capellix plus the Upgrade lcd Kit .

I also tried to unplug and plug all the cables, I used the splitter then I tried without the splitter, nothing works ..

Link to comment
Share on other sites

Hi , i have the same problem, i have tested all the solutions , have you a .hex files on your pc ? Because i think that we can flash the firmware manually , i have found a video where the guy explain the manipulation and it seem it works , the files is on your hard drive on your ' temp ' case  and the name is something like H150i.xxxxxx.Hex , if you find please send it to me so i can check if it works and if we can retrieve our lcd screen ( I still dont have it because i have restored my pc ) 😞

Edited by Cabochard71
Link to comment
Share on other sites

Be careful flashing the firmware file unnecessarily.  That is not a solution for the common "red triangle" connection issue and it could exacerbate a problem with the Commander Core.  The CPU boot error warning is just that... a warning.  Something is not right.  That typically does not happen with LCD top connection issues.  Take a look at the thread linked below and I would start a support ticket with Corsair through the main website.

 

https://forum.corsair.com/forums/topic/173083-icue-417244-elite-capellix-lcd-screen-issue/

 

Link to comment
Share on other sites

Icues not showing the lcd cap like he does the firsst day i have installed it , i have tried all the solutions , with the y cable , without , put the usb directly in the MB , check all connections  , desinstall icue etc etc , i have paid 300 e specially for this screen so if he dont work i want absolutely find a solution ..

I ask the 150i hex file since 3 days and no one can send it to me because i dont have the firmware on my pc so i tought it is my last solution before ask a new one 😕

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...